Eclipse 3.2 and Java 1.4.2

At least one reader of my entry a couple of days ago expressed concern that Eclipse 3.2 might require the use of Java 5. Well it doesn’t. No need for alarm. Apparently there are two plug-ins in the SDK that require the use of Java 5 and if Java 5 isn’t available, those plug-ins just don’t get loaded (apparently these plug-ins have something to do with annotation support presumably in the JDT).

So… there you have it. You can run Eclipse 3.2 on Java 5, but don’t have do. It will run just fine on Java 1.4.2. This should certainly make the GIJ/GCJ folks happy.

This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s